OpsCenter发行说明

OpsCenter发行说明提供有关新的和改进功能的信息,已知和 解决问题和错误修复。

注意力: datastax. OpsCenter 6.8.x发行说明 现在托管在这里: OpsCenter 6.8..4及更高版本说明.

释放影响

了解升级影响,与DSE版本兼容,并已知 issues.

注意力: datastax. OpsCenter 6.8.x发行说明 现在托管在这里: OpsCenter 6.8..4及更高版本说明.

在阅读发行说明之前,请查看以下信息以了解升级影响, 与DataStax Enterprise(DSE)版本的兼容性,以及版本的已知问题 OpsCenter.

升级信息

重要的: 点评审查 升级考虑因素 与发布相关的有关如此 升级DSE OPSCenter.。配置和其他值得注意的更改 detail.

兼容性

要查看OpsCenter 6.x支持哪些版本的DataStax Enterprise(DSE),请参阅 DSE Opscenter与DSE兼容.

笔记: OpsCenter 6.8.0不支持DSE 5.1.x.支持DSE 5.1.x可用 OpsCenter 6.8.4及更高版本。

已知的问题

重要的: 审查 已知的问题 before 在生产DSE集群上运行新的OpsCenter版本。

OpsCenter 6.8..0.发行说明

opscenter.和Lifecycle Manager版本6.8.0的发行说明 release.

dse-env.sh.

默认位置 of the dse-env.sh. 文件取决于类型 installation:
包装安装 /etc/dse/dse-env.sh.
Tarball装置 stappling_location./bin/dse-env.sh.
注意力: datastax. OpsCenter 6.8.x发行说明 现在托管在这里: OpsCenter 6.8..4及更高版本说明.

2020年3月30日

强调

审查 新的功能 in OpsCenter to see 跨版本的最新添加和比较。

6.8.0的变化

此版本中包含以下更改。

  • 修复了在检索时导致404错误的问题 [Agent_Config] 的价值 false from the DSE Agent.
  • 修复了OpsCenter用户界面中的漏洞。 (OPSC-16221)
  • 更新了C3P0库,以防止opsCenter中的漏洞。 (OPSC-16109)
  • 更新jgroup依赖性,以防止opscenter中的漏洞。 (OPSC-16105)
  • 更新的DataStax代理与Java 11兼容。(opsc-15278)
  • 修复了与查询性能服务状态相关的日志记录问题 数据库代理未连接。 (OPSC-13014)
  • 从OpsCenter删除了手机主页功能。 (OPSC-8756)
  • 添加了验证插件框架以允许自定义 验证 战略。 (OPSC-14507)
  • 将默认用户界面的超时从10秒更改为30秒。 (OPSC-15554)
  • 默认情况下添加了LDAP SSL / TLS连接的主机名验证。 (OPSC-16354)
  • 修复了OpsCenter指标存储将错误地将查询限制为节点子集的问题。 (OPSC-12413)
备份服务
  • 修复了在使用成千上万的时造成恢复失败的问题 单个节点和keyspace的SSStables。 (opsc-16463)
  • 修复了在还原期间导致远程文件大小的不需要检查的问题。 (OPSC-16431)
  • 修复了Azure备份问题,在容器具有时不会返回所有数据 超过5000件物品。 (opsc-16409)
  • 运行Select DataCenter的备份时,磁盘空间不再查询 备份中未包含的节点。 (opsc-16407)
  • 修复了防止SSTableLoader旁路还原单个数据中心的问题。这 仅适用于数据中心的新备份。 (opsc-16341)
  • 更正了一个阻止数据中心快照在节点时拍摄的问题 在该数据中心之外与其数据库代理有问题。 (OPSC-16338)
  • 用钥匙空间选择器纠正了一个带有大的群集的性能问题 键盘或表格数。 (opsc-16331)
  • 添加了对SWIFT S3备份和还原的支持。 (opsc-16240)
  • 当节点无法访问A所需的数据时,改进了错误消息 恢复。 (OPSC-16042)
  • 修复了可能导致备份,恢复和的stackoverfloweption的问题 收集指标。 (OPSC-15977)
  • 优化了DataStax代理启动时如何将提交日志传输到目标。 (OPSC-14023)
  • 增加了支持 datastax.图表(DSG) backups. (OPSC-14699)
  • 减少线程死亡的情况。 (OPSC-10385)
  • 将提交日志归档归档失败添加为OpsCenter事件日志中的警报。 (OPSC-14020)
  • 添加了支持配置备份存储目录 (backup_storage_dir.)使用提交日志备份设置。 (OPSC-14496)
  • 修复了使用多级前缀路径作为备份服务的位置时的问题。 (OPSC-14687)
  • 修复了一个问题,如果丢弃后不久拍摄备份,则还原将失败 从表中的一列。 (OPSC-13029)
监测
  • 增加了对新的支持 datastax.图表(DSG) metrics. (OPSC-15876)
  • 删除了以下度量标准,以反映DataStax Enterprise 6.8.0的定义。 (OPSC-15588)
    • 活跃的eventloop-Park
    • 完成-Emperloop-Park
    • 已完成 - EventLoop-Processed-Tasks
    • Active-EventLoop-Processed-Tasks
    • active-eventLoop-schedult-tasks
    • 已完成 - EventLoop-Schedulited-Tasks
    • Active-eventLoop-Selement-Events
    • 已完成 - EventLoop-Selefact-Events
    • active-eventLoop-select-call
    • 已完成 - EventLoop-Select-old
    • Active-eventLoop-Select-opet-calling
    • 已完成 - EventLoop-Select-opet-calling
    • Active-EventLoop-Spin
    • 已完成 - EventLoop-Spin
    • Active-EventLoop-exiting
    • 已完成 - EventLoop-exiting
    • 待定帧解码
    • 全封闭式帧解码
    • 活跃读取的
    • 已完成读取的
    • 等待读取的
    • 全封闭式录取延迟
nodesync.
  • 添加了支持启用和禁用DataStax中引入的增量Nodesync 企业6.8.0。 (opsc-15798)
  • 为增量Nodesync添加了新的Nodesync增量验证涵盖了adeges度量标准。 (OPSC-15654)
供应
  • 增加了能力 specify CASSANDRA_LOG_DIR via Lifecycle Manager by managing dse-env.sh.。 (OPSC-16307)
  • 修复了生命周期管理器中的问题,导致临时文件的移动 file systems to fail when /tmp is mounted on its own file system. (OPSC-15822)
  • 添加了为环境变量配置DSE默认值的功能。 (OPSC-15211)
  • 在SSH凭据形式内的生命周期管理器中编辑SSH键时,键是 现在以单座字体显示。 (OPSC-15087)
  • OpsCenter和DataStax Enterprise不再需要外部二进制文件 which 安装。 (OPSC-14931)
  • 生命周期管理器不允许以下群集名称: opscenter., api, login, logout, rc, and keepalive. (OPSC-14119)
  • 更新日志记录以包括某些依赖项的其他日志记录。 (OPSC-13180)
  • 使UTC默认记录OpsCenter和DataStax代理的日志记录时区。增加时间 区域说明符到日志时间戳。 (OPSC-15405)
维修服务
  • 维修服务临时文件更快地清理。 (OPSC-15982)

OpsCenter 6.8..0.及更高版本的已知和解决问题

OpsCenter和Lifecycle Manager的已知问题,解决方法和解决问题 6.8.0及更高版本。

注意力: datastax. OpsCenter 6.8.x发行说明 现在托管在这里: OpsCenter 6.8..4及更高版本说明.

以下是opsCenter 6.8.0及更高版本中存在的已知问题。每个物品 有一个有关更多细节的链接,包括当可用的变通方法。这些问题将是 在可能的情况下在未来的版本中解决。如果您有任何疑问,请联系 datastax. Support for assistance.

OpsCenter 6.8..0.
  • 使用OpsCenter还原的图表上可能无法显示数据图表查询。发生这种情况 在以下条件下:
    • 使用DSE 6.8.0或更高版本。
    • 恢复的图表使用DataStax图形经典。
    • 还原不使用sstableLoader。
    如果图形为空,请使用OpsCenter执行群集的滚动重启。 重新启动后,应使用图形查询可见数据。 (OPSC-16476)
  • 恢复物化视图时,OpsCenter无法正确等待群集 架构解决,当数据恢复到该表时,可能会导致错误 视图是基于的。 (OPSC-13029)
  • 如果有大约75个或更多的键,DataStax代理 /tokenranges API调用用默认堆大小耗尽内存。作为 临时解决方法,调整 代理堆 size。 (OPSC-11975)
  • 对于DSE版本5.1及更高版本,仅限慢查询数据 自上次重新启动数据库代理以来以来可用。 (OPSC-11702)
  • 暂存目录的权限不足可能导致代理排出inotify 随着时间的推移在系统上手表。 (OPSC-10732)
  • 如果访问群集,用户将看到opscenterd.log中的ungrachful错误+堆栈跟踪 通过不再存在的UI / API。错误消息包含 错误:未处理 延期错误:没有名称或ID的群集......。此错误消息是 无害。 (OPSC-8819)
生命周期经理(LCM)6.8.0
  • 生命周期经理目前兼容DSE 透明数据加密。看 加密DSE配置值 for more details. (OPSC-7529)
  • DSE图表属性:DSE图形配置 DSE.YAML.,这是 可通过LCM配置配置文件配置。所有图形属性 DSE.YAML. 可以通过LCM UI管理 gremlin_server.serializers and gremlin_server.scriptEngines。如果您使用的是LCM并需要 自定义这些属性,一定要利用 LCM. API 做出改变。使用LCM UI对配置文件的未来更改 将保留通过API设置的属性。
  • 在存储库中配置凭据时,特殊字符如#,$等 支持,但非ASCII Unicode字符不支持。 (OPSC-8921)