PHP司机

PHP驱动程序的驱动程序兼容性表。

Apache Cassandra的DataStax PHP驱动程序®

桌子 1. 矩阵表图标传奇
图标 描述
完全兼容。
部分兼容。
不相容
最新的未成年人开发了新功能和错误修复 鼓励司机的版本,并鼓励用户保持当前 那些小版本。 API根据稳定维持稳定 语义版本化 惯例和升级 should be trivial.
笔记: DSE驱动程序功能已被合并,现在在开源开发 上面的数据库驱动程序。

图标传奇

驱动程序版本 Apache Cassandra / DDAC版本 DataStax Enterprise Version. Datastax Astra.
版本 3.0+ 2.2 2.1 5.1 5.0 4.8
1.2+
1.1 3 3 3 3
1.0 4 4

2虽然OSS驱动程序能够连接到DSE集群,但 我们强烈建议升级到DSE驱动因素,以便充分利用所有DSE功能。

3限于Cassandra 2.1 API

4仅限于Cassandra 2.0 API。

DataStax Enterprise PHP驱动程序

笔记: 虽然OSS驱动程序能够连接到DSE集群,但我们强烈推荐 升级到DSE驱动程序,以充分利用所有DSE功能。

图标传奇

驱动程序版本 DataStax Enterprise Version. Datastax Astra.
版本 5.1 5.0 4.8
1.1
1.0 1

1限于DSE 5.0 API。