node.js驱动程序

DiveS.js驱动程序的驱动程序兼容性表。

Apache Cassandra的DataStax Node.js驱动程序®

桌子 1. 矩阵表图标传奇
图标 描述
完全兼容。
部分兼容。
不相容
最新的未成年人开发了新功能和错误修复 鼓励司机的版本,并鼓励用户保持当前 那些小版本。 API根据稳定维持稳定 语义版本化 惯例和升级 should be trivial.
笔记: 早期版本的DataStax Cassandra驱动程序没有完全支持DSE features.

图标传奇

Driver version Apache Cassandra版本 DataStax Enterprise Version. Datastax Astra.
版本 3.0+ 2.2 2.1 6.8 6.7 6.0 5.1 5.0
4.5
4.4 1
3.0+ 1 1 1 1 1

1早期版本的DataStax Cassandra驱动程序没有 完全支持DSE功能。

DataStax Enterprise Node.js驱动程序

笔记: DSE驱动程序功能已被合并,现在在开源开发 上面的数据库驱动程序。

图标传奇

驱动程序版本 DataStax Enterprise Version. Datastax Astra.
版本 6.8 6.7 6.0 5.1 5.0
2.3+ 4
1.6+ 2
1.3+ 2 2 2
1.0+ 3 3 3 3

2限于DSE 5.1 API。

3限于DSE 5.0 API。

4仅限于DSE 6.7 API。